You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. Thomsterdam
  2. JCE Editor
  3. Tuesday, 05 February 2019
Hi there,
In hope that I wouldn't have to ask this question, I searched your website and found this page https://www.joomlacontenteditor.net/support/forum/88982-absolute-links containing this link: (https://www.joomlacontenteditor.net/support/forum/use-both-relative-and-absolute-urls-in-links) but unfortunately the link is dead.

So here we go:
I need both absolute and relative links in JCE. Is that possible? if so, how?

I prefer to use relative links everywhere on my website. Having said that: JCE also opens when I edit emails and forms in RS Form! Pro. The Thank You Email that is sent, should contain something like "You can download your free gift here: https://www.thomsterdam.nl/free-gift" (FYI: there is nothing to see at this link). When I save the email in JCE and RS Form the links are changed to relative links and the email that is sent after filling in the form, has relative links that are - obviously - dead.

Can you help?

Thanx,


Thom
Accepted Answer Pending Moderation
In the Editor Global Configuration, add the following to the Custom Configuration Variables field:


mixed_urls:true


eg:

https://cdn.joomlacontenteditor.net/tmp/98127-use-both-absolute-and-relative-links.jpg
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
Hi there,
Great! Thanx for your quick answer!

This works! However..... (here we go :o )

Is it possible to disable absolute links for articles and enable it for RS Form? Or, this would work as well: enable it for some users and not for others? Some of my clients will do the weirdest stuff in their articles (e.g. they use http:// instead of https:// or vice versa (or other variants...)) and forcing them to use relative links (in these articles) would save me a lot of hassle, whereas I would still be able to make absolute links in the RS Form mails.

Thanx,


Thom
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
Remove the mixed_urls setting from the Editor Global Configuration.

In the Editor Profiles list, select the "Default" profile (or whichever is you main profile) and click the Copy button.

Then:

1. Click in the new profile to edit it
2. Give it a new Title and Description, eg: RS Form, Profile for RS Form.
3. Set Ordering to Order First.
4. Set Components to Select From List and select RS Form in the list.
5. Click on the Editor Parameters tab, and set Relative URLs to No.
6. Make any other changes you require for this profile.
7. Save.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Hey Ryan,

Almost too good to be true. Thanx!

Cheers,


Thom
  1. more than a month ago
  2. JCE Editor
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.