You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. pici
  2. JCE Plugins / Addons
  3. Friday, 25 January 2019
Hello
If I load a file (for example PDF) in home
and I have enable a plug for popup (like JH Image Popup or mAvik Thumbnails)
the link of the file (with the preview) not play in homepage
only if I go to the article.
If I disable the plug for popup all return normal, also in homepage.
In which way I can fix the problem?

Thanks
References
  1. https://ufficiopellegrinaggi.diocesifrosinone.it/
  2. https://ufficiopellegrinaggi.diocesifrosinone.it/prossimi-pellegrinaggi/122-pellegrinaggi-2019.html
Accepted Answer Pending Moderation
If I disable the plug for popup all return normal, also in homepage.


It would appear that this plugin, or some other plugin you have installed, is altering the links on the homepage, which is why they are not working as expected, eg:

homepage link:


<span style="font-size: 12pt; font-family: arial,helvetica,sans-serif;">
<a class="wf_file" href="/images/locandine/2019/FATIMA_UDP_FROSINONE_12_15_SEP_2019.pdf"></a>
<a href="/prossimi-pellegrinaggi/122-pellegrinaggi-2019.html" class="wf_file_icon thumbnail" style=""><img class="wf_file_icon" style="border: 0px; vertical-align: middle; max-width: inherit;" src="/media/jce/icons/pdf.png" alt="pdf"></a>
<span class="wf_file_text">FATIMA_UDP_FROSINONE_12_15_SEP_2019.pdf</span>
</span>


article link:


<span style="font-size: 12pt; font-family: arial,helvetica,sans-serif;">
<a class="wf_file" href="/images/locandine/2019/FATIMA_UDP_FROSINONE_12_15_SEP_2019.pdf">
<img class="wf_file_icon" style="border: 0px; vertical-align: middle; max-width: inherit;" src="/media/jce/icons/pdf.png" alt="pdf">
<span class="wf_file_text">FATIMA_UDP_FROSINONE_12_15_SEP_2019.pdf</span>
</a>
</span>
Just because you're not paranoid doesn't mean everybody isn't out to get you.
Accepted Answer Pending Moderation
Yes
thanks
some help to fix the problem and use plug and JCE?

Thanks
Accepted Answer Pending Moderation
This issue is not caused by JCE, but by the extension making the changes to the link. You will need to disable that extension, or find an alternative.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
Accepted Answer Pending Moderation
Yes, I know very well that JCE not caused that problem.
But with every plug for the image the problem in home, with JCE, is present.
In fact I have tested two, as You can see up.

Anyway only Image Sizer has solved the conflict.

Thanks
Accepted Answer Pending Moderation
One thing you can try is to insert the pdf link without the Icon option checked, and then add this to your template stylesheet to display the icon:

a[href$=".pdf"]::before {
content: "";
display: inline-block;
background: url('media/jce/icons/pdf.png') no-repeat center;
padding: 8px 12px 8px;
vertical-align: middle;
}
Just because you're not paranoid doesn't mean everybody isn't out to get you.
Accepted Answer Pending Moderation
Thanks a lot for the wonderful suggest.
Have a good Sunday
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.