You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. lawrenceporter
  2. JCE Editor
  3. Friday, 02 December 2016
I have just upgraded to JCE Pro specifically for the Markdown support.

The markdown works beautifully as you type in the content field. But this is not what I need!

I would like my editors to be able to prepare their articles in markdown offline in their favourite text editor and paste the complete article into the JCE content window. Then to have it automatically interpreted. This doesn't happen. The text remains as is with all the markdown showing.

If you hit a carriage return after every line (and then delete the unwanted new line) the markdown is interpreted line by line. But this isn't practical for a normal-length article.

Is there a way I can paste in markdown and have it interpreted immediately?

If not, could we have a button in the editor icons which does this?
Accepted Answer
Accepted Answer Pending Moderation
That seems perfectly reasonable and quite obvious but to be honest it never occurred to me!

The Markdown feature is based on the Textpattern plugin in TinyMCE, which does not include paste processing. Unfortunately this means I am going to have to come up with a solution, which I hope will not be too difficult.

I will see if I can get this done in 2.6.2, or at least by 2.6.3 :)
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # Permalink
Accepted Answer Pending Moderation
Thanks Ryan - much appreciated!

Lawrence
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
Sorry to re-open this post, but it seems that you haven't find a way to enable markdown on paste. Is that correct?
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
Support for markdown text to html conversion on paste, and when toggling the editor, will be added in JCE Pro 2.6.27

When pasting, the markdown text must be plain text, ie: it has been copied from a text source like Notepad, TextEdit etc.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Thank you. I will wait for that release.
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
JCE Pro 2.6.27 is now available - https://www.joomlacontenteditor.net/downloads/editor/pro/latest

To activate the markdown to html conversion on paste, you need to set an option in the Custom Configuration Variables field in the Editor Global Configuration, eg:


textpattern_use_markdown:true


https://cdn.joomlacontenteditor.net/images/news/2627/textpattern_use_markdown.jpg
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
Hi Ryan,

Many thanks for this!

I just tested it and it works a treat!

Lawrence (Original Poster)
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Hi, two things.

1. Could you please add this information on your markdown docu page

2. I just tried with 2.6.35 and it does not work for me. Do I have to do with this version more?
  1. more than a month ago
  2. JCE Editor
  3. # 7
Accepted Answer Pending Moderation
@svanschu - Is the Markdown option enabled in Editor Profiles -> Features & Layout?

https://cdn.joomlacontenteditor.net/tmp/87773-how-do-i-paste-in-markdown-2.jpg
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 8
Accepted Answer Pending Moderation
@svanschu - Is the Markdown option enabled in Editor Profiles -> Features & Layout?

https://cdn.joomlacontenteditor.net/tmp/87773-how-do-i-paste-in-markdown-2.jpg


Sorry for the late response.
Yes it is activated. If I type markdown by hand, it works as expected. If I copy and paste a markdown text, i does not work at all.
  1. more than a month ago
  2. JCE Editor
  3. # 9
Accepted Answer Pending Moderation
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 10
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.