You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. albertasky
  2. JCE Editor
  3. Saturday, 28 November 2020
Hi there. Is there a way of turning off the shortcode feature in JCE? I can't find this option anywhere. Here's my issue:

I'm using RSForms. When I email users or admins using RSForms, I'm able to include form fields within the email provided they are enclosed in braces; e.g., {firstName:value}.

JCE appears to be changing my code automatically to the following:
<false data-mce-code="shortcode">{firstName:value}</false> or instead of false tags, true tags.

Either way, it's impacting the final result on my form (e.g., some of my span tags are removed, <br> missing, etc.).

This is the desired result:
Desired Result.png

This is what is viewed in the Editor tab:
Editor Screen.png

Here's how it looks in the Preview tab:
Preview.png

I'm not sure if there's just a simple setting somewhere that I've missed?

Thanks for any help you can provide.

Tim
Attachments (3)
Accepted Answer
Accepted Answer Pending Moderation
In Editor Profiles -> Editor Parameters -> Advanced, set Protect Shortcode to No.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # Permalink
Accepted Answer Pending Moderation
Ah, thank you. I don't know how I missed that! Works as advertised.

Tim
  1. more than a month ago
  2. JCE Editor
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!