You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. vjer
  2. JCE Plugins / Addons
  3. Monday, 17 August 2020
Hi, new JCE Pro 2815 user, trying to set up S3 Filesystem.

So far I am able to create folders in S3 (following file directory path: images/authors/$username), however still no luck uploading images. After trying an upload, I get message: 'The server returned an invalid JSON response.'

Ive followed the set up instructions, wondering what I mightve missed..

Thanks
Accepted Answer
Accepted Answer Pending Moderation
I ahve fixed this on your site with an update of the S3 Filesystem plugin, but there is an issue with the name of your S3 bucket. Because it contains ".com", it is creating an invalid url when used to produce the url for any media in the bucket.

You will need to change the bucket name, or use a CName for the bucket.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # Permalink
Accepted Answer Pending Moderation
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 1
Accepted Answer Pending Moderation
sent, thank you :)
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 2
Accepted Answer Pending Moderation
I need to be able to access the JCE Editor Profiles, but your login does not allow me to.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 3
Accepted Answer Pending Moderation
Sorry Ryan, I changed it to super user
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 4
Accepted Answer Pending Moderation
Have you checked the S3 Access Key and Secret Key using another S3 client?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 5
Accepted Answer Pending Moderation
i do use s3 for another website, i'll create a new aws account to separate them
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 6
Accepted Answer Pending Moderation
so i created a new aws s3 account, using new root user access keys- but same result. Creating folders and subfolders are fine, but still unable to upload images to them.

The json response appears to be like this:
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>E673E8631B1E661B</RequestId>
<HostId>
OnNs2v4iHC0cfa5S6V4OLwCRuMkacVKwuaoqQkwLlKrxIyqBTDDw5RIvHj+Zgjrc81NBDlmEAPo=
</HostId>
</Error>

anything else i can check on the aws side?
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 7
Accepted Answer Pending Moderation
The bucket permissions are probably incorrect. Please see the example IAM permissions at the bottom of this article - https://www.joomlacontenteditor.net/support/documentation/filesystem-for-amazon-s3/configuration
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 8
Accepted Answer Pending Moderation
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 9
Accepted Answer Pending Moderation
ive set the bucket policies per example, still no joy.. also tried it with even more permissions but still nothing. also double checked my IAM user policy, even using my root user access key, but still same error.

is it strange that i can create/delete/list folders correctly, but not put objects?
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 10
Accepted Answer Pending Moderation
Thank you Ryan!
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 11
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!