You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. hayesjames
  2. JCE Plugins / Addons
  3. Friday, 29 May 2020
Hi there,

Just got back into Joomla and am still loving your editor. I've purchased the Pro to get the ability to add video to an article easily. However, I (well the client!) want to create video as the thumbnail for the articles so I've created a custom field and set it to the JCE Media Browser, but it cannot find MP4 and says they are unsupported? I can however add to articles no problem.

I have solved the problem by creating a text field and adding the URL of the video from media manager to that field, but you know clients are stupid and using the media browser to locate the file would be easier for their simple minds!!

Cheers
James
Accepted Answer Pending Moderation
By default the Media JCE field, or the Joomla Media field, when using the JCE File Browser, only supports image insert.

It can be configured to allow all file types - this can be set when creating the JCE File Browser media field - but this will only insert the file as a link, it will not embed the file if it is a video for example.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 1
Accepted Answer Pending Moderation
Hi Ryan,

Im having the same issue as James. I have manually added a custom field to our plugin.
The fieldtype is 'mediajce'. Our goal is to upload and select an .mp4 file. Im able to upload and see .mp4 files via the JCE File Browser.

Adding the .mp4 file via the custom field gives me an warning 'filetype not allowed'.

It can be configured to allow all file types - this can be set when creating the JCE File Browser media field


I have searched for the settings mentioned above, but i am not able to find it.
Are you able to send a screenshot.

Best regards,

Jamie
Attachments (3)
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 2
Accepted Answer Pending Moderation
Add a mediatype attribute to your field tag with a value of mp4, eg: mediatype="mp4"
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 3
Accepted Answer Pending Moderation
Works thanks!
  1. more than a month ago
  2. JCE Plugins / Addons
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!