You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. forensis
  2. JCE Editor
  3. Friday, 26 July 2019
The JCE editor always inserts a <div> </ div> into a new empty post.
Where / How can I prevent this permanently? The post must be completely empty!

Regards,
fori
Accepted Answer
Accepted Answer Pending Moderation
By default, the editor will create an empty paragraph in a new article. If this paragraph is left empty, and the article is saved, then the empty paragraph is removed.

If however, you have set the editor to use <div> as the default container element in the Editor Global Configuration, then an empty <div></div> will not be removed when the article is saved.

This may be corrected in the next update.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # Permalink
Accepted Answer Pending Moderation
Thank you! Then I'm looking forward to the next update.

My problem is that a particular teaxtarea field must be completely empty when it's not in use. In "SobiPro" there is a corresponding query, which makes disappear the whole tab only with really empty textarea-field the tab contained.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
I thought version 2.7.16 resolved the problem.

But has the <div> tag error crept in in the meantime? Or am I doing something wrong?
I've now installed JCE 2.7.18, and again, everywhere in an empty editor at the moment of saving, these <div> </ div> tags are set - no matter how the "container item & enter key" setting is configured!

How to resolve the problem?

Regards, fori
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
I'm not seeing this issue returned in my tests. Please try JCE Pro 2.7.19 Beta 4 - https://www.joomlacontenteditor.net/downloads/editor/pro/development
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Yes right, if I save a simple empty Joomla post, then no div tags are set. This works in the backend as well as in the frontend.

But the JCE is also the editor for the DPCalendar (Digital Peak). And if I save the description for an event, the div-tags are set here! (Also in the back and in the frontend). See attachement.

How is that possible?
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
But the JCE is also the editor for the DPCalendar (Digital Peak). And if I save the description for an event, the div-tags are set here! (Also in the back and in the frontend).


I am not able to reproduce this in the free version of DPCalendar.

Please send me a login - https://www.joomlacontenteditor.net/contact/site-login
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
I am unable to replicate this issue in a Test event on your site. I have tested in Firefox and Chrome.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Now I have set two test dates, one on 20.10. and one on 27.10.
If I click Edit right after saving, I see nothing in the editor code, or just a space without code.
If I then delete this (invisible) space and Save, the div tags immediately appear and then remain. Both in Firefox and in Chrome. See screenshots.

And that does not happen to you? What is wrong with me then?
Attachments (3)
  1. more than a month ago
  2. JCE Editor
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!